AWS Migration Completion
Incident Report for CrystalCommerce
Resolved
The following issues have been resolved:

Back end (Admin):
POS timeouts / slow load times.
Slow load times in the admin.
Saving inventory adjustments taking very long/save & next button broken.
Mass Create jobs are not processing.
File Reports are not exporting.

Front end (Website):
Broken CSS Styles (Layout/branding colors) on frontend websites.
Slow checkout times, especially with PayPal payment option.
Batch Updates not completing / timing out.
Posted Jan 16, 2019 - 09:02 PST
Update
We have also discovered that one of the IP addresses required for your A records has changed after the migration. We apologize, but the DNS settings must be updated again. Here are the two IP addresses that must be entered as your A records:

13.52.65.57
13.52.91.176

Your CNAME www now needs to point to, or have a value of:
alb-prod.crystalcommerce.com

Your CNAME store also needs to point to, or have a value of:
alb-prod.crystalcommerce.com

You can create the 'store' one if you do not have it

Please review the help article below for further information:
http://help.crystalcommerce.com/launch-your-online-store/step-4-getting-your-website-ready/pointing-your-dns
Posted Nov 21, 2018 - 16:43 PST
Identified
The support team is rigorously working with the devs to get your admins and websites optimally performing today. Bear with us as we do expect the symptoms to continue for a bit longer.

A little back story: The objective to moving to AWS is to get you guys up and running prior to Black Friday in a server environment that is going to dynamically produce resources as business spikes this week and for the holiday season. Based on how bad the IBM servers did with the weekend load last weekend, we are rigorously testing and working around the clock with our support and dev teams together to get you up and running TODAY.

If you notice any issues that are not related to those you see in the list below, please notify the support team with any or all of the following: Visual examples, where you’re seeing the unknown issue coming from, or any other pertinent data for investigation.

Known issues are:

Back end (Admin):
POS timeouts / slow load times.
Slow load times in the admin.
Saving inventory adjustments taking very long/save & next button broken.
Mass Create jobs are not processing.
File Reports are not exporting.

Front end (Website):

Broken CSS Styles (Layout/branding colors) on frontend websites.
Slow checkout times, especially with PayPal payment option.
Batch Updates not completing / timing out.

Actively working on:
Tuning the AWS servers.
Restoring admin functionality.
Restoring POS functionality.
Restoring Website

Expectation of solutions
Expect to see improvements starting today, including:
Front end stability, including checkouts
POS stability and speed
Admin stability and speed, including all inventorying tools like; Mass create, batch updates
Posted Nov 21, 2018 - 12:58 PST
This incident affected: Admin, POS, Frontend, and Batch Update.