Downtime
Incident Report for CrystalCommerce
Resolved
This incident has been resolved.
Posted Aug 08, 2024 - 12:54 PDT
Monitoring
The issue has been resolved. It may still need some time for the DNS to propagate., but we are seeing things come back online now. If it still isn't for you, it should be soon. We are continuing to monitor the situation to make sure everything is fully functional.

Note that we flagged TCGPlayer as operational, but it may still take some time for them to enable it. They had shut down the integration on their end until the issue was fixed in order to avoid complications due to us not being able to sync with them
Posted Jun 25, 2024 - 18:47 PDT
Update
We were able to get the nameservers reverted just now, which means now we need to wait for the DNS to propagate. After that, we should start seeing everything come back online. Currently, we are seeing errors, but those could be related to the DNS not propagating yet. We are continuing to work on this and monitor these errors, but this is a big step in the right direction towards getting this resolved.
Posted Jun 25, 2024 - 17:58 PDT
Identified
There's an issue with our crystalcommerce.info domain. AWS released it to another company named Gandi. During this process, the nameservers were updated, which took the system down. This is not something that is supposed to happen according to ICANN policy. The nameservers should have remained unchanged. We have been in communication with AWS regarding this, as well as contactd Gandi regarding regaining access and/or reverting the nameservers (reverting the nameservers would solve the problem).
Posted Jun 25, 2024 - 11:06 PDT
Investigating
We are currently experiencing downtime across our system. Our developers are investigating, and working on getting the system up and running as soon as possible.
Posted Jun 25, 2024 - 09:42 PDT
This incident affected: Admin, POS, Frontend, Batch Update and 3rd Party Integrations (Amazon, eBay, TCGplayer, Endicia).