Slow load times / 502 & 504 errors
Incident Report for CrystalCommerce
Postmortem

We observed 2 large spikes in response time at 9:00am and 11:45am and one lesser spike at 2:2pm (Pacific Time), causing 504/502 errors and increased page load times. Although the issue has subsided, our engineering team is working behind the scenes on preventative measures to ensure that this MTG prerelease weekend will go smoothly.

Posted Apr 21, 2022 - 02:38 PDT

Resolved
This incident has been resolved. Our engineers will continue to monitor.
Posted Apr 21, 2022 - 01:49 PDT
Investigating
We are seeing 504 and 502 errors while attempting to use CrystalCommerce services, along with slow load times. Our engineering team is currently investigating.
Posted Apr 20, 2022 - 11:37 PDT
This incident affected: Admin, POS, and Batch Update.