Amazon MWS Integration Down
Incident Report for CrystalCommerce
Resolved
This incident has been resolved.
Posted Nov 23, 2020 - 11:42 PST
Update
We are seeing some shipped orders come in without line items on them yet, we are working to populate them now. We are also testing functionality for new orders, making sure that line items will come in correctly. Please continue to leave your Amazon account in Vacation mode until we confirm things are working correctly. We are approaching the finish line and will post another update here shortly.
Posted Nov 10, 2020 - 15:43 PST
Update
We are continuing to monitor for any further issues.
Posted Nov 10, 2020 - 15:21 PST
Monitoring
It looks like the problem has been fixed. FetchLineItems for the Amazon integration started working again at 2:45! We are continuing to monitor.

****Regarding shipped Amazon orders, we have multiple restore/reactivate options for you based on what would be most helpful. To begin with we're importing all orders, without adjusting inventory levels. If you want help with inventory adjustments from the orders let us know on chat to keep it in one spot. These orders will not be charged. ****
Posted Nov 10, 2020 - 15:19 PST
Update
We are now working to reactivate. We finally got through and found an engineer within Amazon who was able to assist Dan with recovering the access needed to restore services. We're moving forward and will report more as soon as possible.
Regarding shipped Amazon orders, we have multiple restore/reactivate options for you based on what would be most helpful. To begin with we're importing all orders, without adjusting inventory levels. If you want help with inventory adjustments from the orders let us know on chat to keep it in one spot. These orders will not be charged.
Posted Nov 10, 2020 - 14:30 PST
Update
We are waiting for a patch to be rolled out by Amazon for our issue, they said hopefully this week they will be able to. We will continue to push Amazon on this issue until we see resolution.
Posted Nov 09, 2020 - 15:48 PST
Update
Amazon were not able to implement a fix for us last night. They did say that they hope to get a patch ready for us next week. We will continue to push Amazon to get the fix out for us as soon as possible on this one and will reach out to them daily and keep you uptodate.
Posted Nov 07, 2020 - 12:07 PST
Update
Our CEO, Dan and our engineering team have been in meetings with Amazon over the last several days and this morning. We finally have some more specifics from Amazon regarding the issue.
When our account with Amazon was first set up, Amazon allowed the same email/password to be used for both a regular Amazon account and MWS account. That is no longer the case, and two separate logins are now required. However, Amazon didn't make any changes to our account when this old system was done away with. Because of that, it's attempting to use Amazon's legacy system that is no longer in place when we try to log into MWS, resulting in an error.
Amazon MWS support informed us that they cannot fix this on their own, and they are enlisting the help of another team at Amazon, the Identity Team, to fix the issue.
Posted Nov 05, 2020 - 14:28 PST
Update
Our engineering team had a meeting with Amazon MWS support this afternoon (it had originally been set for this morning, but Amazon rescheduled). We are still having to wait for Amazon support to resolve the issue with our primary account so we can access our new MWS key and restore the sync.

We've re-iterated to Amazon that it isn't just our MWS account that is being affected, but that it is affecting hundreds of Amazon sellers as well. Amazon told us that they are trying their best to get this fixed asap.
Posted Nov 04, 2020 - 15:07 PST
Update
The meeting that took place yesterday led to progress and the ticket has been passed on to another department of Amazon that is going to work on verifying our business information. They are now requiring that we re-verify our business. we are going to check back in this afternoon on the ticket.
Posted Nov 03, 2020 - 12:50 PST
Update
We've been contacting Amazon continuously over the past week to find a resolution to this issue. Our Amazon account representative set up a meeting for 11AM PST today with their team and ours. New keys have been issued for our account, but we are currently blocked by Amazon's website not allowing us to view the keys. After the meeting, we will have another update on the status of Amazon restoring our access. We want to thank you for your patience while we work with Amazon to get unblocked and restore the ability to use the Amazon integration.
Posted Nov 02, 2020 - 11:32 PST
Update
We are continuing to work with Amazon to receive new API keys.
Posted Oct 29, 2020 - 12:06 PDT
Update
We have connected with their account management team and have escalated the key creation issue. All engineering updates needed on our end are complete. Expect that we should be ready to reactivate once the new key is confirmed. We're waiting for a call back momentarily to troubleshoot further.
Posted Oct 28, 2020 - 12:21 PDT
Identified
Amazon discovered a potential security issue with our current API key, and revoked access. This security issue would not have affected your Amazon account, nor your Crystal Commerce account, just our Amazon developer account.
We are currently working with Amazon to get new API keys issued so that we can return Amazon sync services back to normal asap.
Posted Oct 26, 2020 - 13:24 PDT
Update
We are continuing to investigate this issue.
Posted Oct 25, 2020 - 13:02 PDT
Investigating
There is currently an issue where Amazon orders are not coming into your CrystalCommerce admin panel. Our developers are working on getting this resolved as soon as possible.
Posted Oct 23, 2020 - 17:59 PDT
This incident affected: 3rd Party Integrations (Amazon).