Extended load times
Incident Report for CrystalCommerce
Resolved
This incident has been resolved. We will continue to monitor.
Posted May 24, 2023 - 16:30 PDT
Monitoring
We are observing longer than normal wait times to access CrystalCommerce services/webpages, and occasional 502 errors. Our engineering team has been investigating and has identified a potential issue. A potential fix has been rolled out as of 3:30 PM Pacific time. Our team is monitoring.
Posted May 24, 2023 - 15:37 PDT
This incident affected: Admin, POS, Frontend, and Batch Update.