"This website is under heavy load (queue full)" errors
Incident Report for CrystalCommerce
Resolved
We deployed a fix, and the system is running smoothly now. We also added some safeguards for automatically handling long-running queries that can bog things down.
Posted Apr 21, 2022 - 16:01 PDT
Monitoring
Our engineers need to restart services, you may experience interruptions briefly and then we anticipate errors to subside. We will continue to monitor during this process. We apologize for the interruption.
Posted Apr 21, 2022 - 13:19 PDT
Identified
Our developers made some adjustments to our server instance count, scaling, and health checks, but we are still getting reports of errors when using the Point of Sale and Admin panel. They are continuing to investigate and make changes as needed.
Posted Apr 21, 2022 - 12:55 PDT
Investigating
Users are experiencing "This website is under heavy load (queue full)" errors when attempting to use CrystalCommerce services. Our engineering team is currently investigating the issue.
Posted Apr 21, 2022 - 12:53 PDT
This incident affected: Admin, POS, Frontend, and Batch Update.