Degraded Website Performance and File Exports

Incident Report for CrystalCommerce

Update

File Exports are working again.
Posted Feb 12, 2025 - 13:29 PST

Identified

We are seeing spikes in response times on websites that are leading to "Website is under Heavy Load" errors. We are seeing unusual activity hitting the sites that we are working on resolving.
Our File Exports are also currently down. This is related to the frontend performance issues. We have been working on a fix, which is currently on staging servers. We will be deploying it as soon as it passes testing.
Posted Feb 12, 2025 - 11:59 PST
This incident affects: Admin and Frontend.